Authorize.Net error: Unable to Authorize Payment: :This transaction has been approved.
Posted by - NA -, Last modified by Wayne Smith on 18 November 2011 02:59 PM
Title
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Authorize.Net: Unable to Authorize Payment: :This transaction has been approved.:


Symptom
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Error: Unable to Authorize Payment : This transaction has been approved.:


Cause
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We just discovered a new Authorize.net problem. The Authorize.net payment module communicates with Authorize.net with the Direct Response method. We pass certain variables to them and they return other variables with different codes and such, like the Response Codes you've seen on another issue.


Solution
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Anyway, there is a setting in the Authorize.net Manager that allows the customer to change the format of these codes that are sent. It allows them to encapsulate, or surround, the codes with different characters. In the case of the error message above, the customer had the encapsulation set to colons ( : ). Unfortunately, Miva Merchant doesn't know how to deal with these extra characters. Please see below on how to correct this.

1. Login to Authorize.net Manager.
2. Click on Settings.
3. To the right, under Transaction Response, click on "Direct Response".
4. The field labeled "Field Encapsulation Character" needs to be set to nothing.
5. Click 'Submit' and you should be all set.
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