Miva Merchant Synchro v1.76
Posted by Wayne Smith, Last modified by Wayne Smith on 23 July 2018 02:00 PM

Miva Merchant Synchro

System requirements for Miva Merchant Synchro are below. This application does require a license key and that can be purchased directly off our website.

Click here to purchase

Miva Synchro connector (synchro5.mvc) version 1.76 and can be downloaded @ here.  Contact Miva Merchant Support if you have any questions.

System Requirements: Microsoft Windows XP or Windows Vista; QuickBooks Pro, Premier and Enterprise, 2004-2012 (Quickbooks not included)

 

v1.76 Released on 7/23/18

 

 



Attachments 
 
 synchro-v1.76.exe (3.62 MB)
(4 vote(s))
This article was helpful
This article was not helpful

Help Desk Software by Kayako support.miva.com/supportsuite/index.php?